首页 / 资讯中心 / 文章详情

云服务器nacos搭建-集群持久化

云服务器nacos搭建-集群持久化 ★ FEATURED ARTICLE
云服务器nacos搭建-单机-CSDN博客默认MODEcluster集群方式启动如果单机启动需要设置-m standalone参数否则启动失败。账号密码nacos/nacos。https://blog.csdn.net/guo13313/article/details/166994619?sharetypeblogdetailsharerId166994619sharereferPCsharesourceguo13313spm1011.2480.3001.8118部署架构图实际生产环境中不同节点部署在不同机器上。在此只做演示练习在同一台机器上进行部署分配不同的端口。节点目录端口nacos88188818nacos88288828nacos88388838从之前的单机部署先复制一个节点8818#创建存放集群节点的目录mkdir nacos_cluster# 复制cp -r nacos8848/ nacos_cluster/nacos8818持久化改造# nacos自带嵌入式的derby数据库作为存储多节点集群部署存在一致性问题解决方案为采用集中存储方式--mysql1.nacos/conf 目录下找到nacos-mysql.sql文件2.执行脚本准备一个mysql数据库用于执行脚本mysql-seatadocker run -d \ -p 3336:3306 \ -v /mysql/conf:/etc/mysql/conf.d \ -v /mysql/data:/var/lib/mysql \ -e MYSQL_ROOT_PASSWORD123456 \ --name mysql-demo \ mysql:8.0.30执行脚本执行完生成如下12个表修改mysql配置nacos/conf目录下找到 application.properties注释放开、修改先·改造单台nacos集群模式修改堆内存大小配置内存够用可不用配置/bin目录下的startup.sh修改:set nu (93行修改)修改cluster.conf配置# 类似192.168.6.100:8818192.168.6.100:8828192.168.6.100:8838再·复制其他节点上面所有配置修改完成后复制另外2个节点并修改端口#复制节点cp -r nacos8818/ nacos8828/cp -r nacos8818/ nacos8838/#修改端口 8828/8838vim nacos8828/conf/application.propertiesvim nacos8838/conf/application.properties启动三台机器./nacos8818/bin/startup.sh./nacos8828/bin/startup.sh./nacos8838/bin/startup.sh查看进程ps -ef |grep nacos任意节点访问nacos部署了3个节点多出一个内网ip端口修复见末尾部分nginx 负载均衡准备一个nginx# 拉取镜像并启动 docker run -d --namenginx6666 -p 6666:6666 -v nginx_conf:/etc/nginx -v nginx_html:/usr/share/nginx/html -v nginx_logs:/var/log/nginx nginx找到配置文件nginx.confdocker volume lsdocker inspect nginx_conf修改配置upstream nacoscluster{ server 8.160.170.126:8818; server 8.160.170.126:8828; server 8.160.170.126:8838; } server{ listen 6666; server_name 8.160.170.126; location / { proxy_pass http://nacoscluster; } # 其他配置docker restart nginx访问http://8.160.170.126:6666/nacos提示错误ERR_UNSAFE_PORTChrome/Edge 浏览器默认把6666 标记为不安全端口直接拦截访问不会发起网络请求。 参考浏览器黑名单端口列表6666 在里面历史上木马常用端口。调整其他端口docker run -d --namenginx8088 -p 8088:8088 -p 80:80 -v nginx_conf:/etc/nginx -v nginx_html:/usr/share/nginx/html -v nginx_logs:/var/log/nginx nginx同步修改配置后启动浏览器访问upstream nacoscluster{ server 8.160.170.126:8818; server 8.160.170.126:8828; server 8.160.170.126:8838; } server{ listen 8088; server_name 8.160.170.126; location / { proxy_pass http://nacoscluster; } # 其他配置可能遇到的问题启动报错--cluster.conf忘记配置./startup.sh启动会报错上面的错误集群节点多了 内网端口部署了3个节点上面多出了一个是内网ip端口需要在application. 增加配置### Specify local servers IP:nacos.inetutils.ip-address公网ipnacos.server.ip公网ip# /conf下的cluster.conf确认是否自动添加了内网ip需要删除自动添加的内网ip删除 protocol的内容rm -rf nacos8818/data/protocolrm -rf nacos8828/data/protocolrm -rf nacos8838/data/protocol# 修改后重新启动nacosps -ef|grep nacoskill 368 471 32447#./nacos8818/bin/startup.sh./nacos8828/bin/startup.sh./nacos8838/bin/startup.sh最终实现只有3个节点了部署了3个节点上面多出了一个是内网ip端口需要在application. 增加配置### Specify local servers IP:nacos.inetutils.ip-address公网ipnacos.server.ip公网ip# /conf下的cluster.conf确认是否自动添加了内网ip需要删除自动添加的内网ip删除 protocol的内容rm -rf nacos8818/data/protocolrm -rf nacos8828/data/protocolrm -rf nacos8838/data/protocol# 修改后重新启动nacosps -ef|grep nacoskill 368 471 32447#./nacos8818/bin/startup.sh./nacos8828/bin/startup.sh./nacos8838/bin/startup.sh最终实现只有3个节点了端口黑名单浏览器限制直接阻止请求6666参考浏览器黑名单端口列表6666 在里面历史上木马常用端口。开发环境推荐端口‌3000-3999前端框架默认、5000-5999后端 API、8000-8999测试环境、9000-9999工具服务。‌绝对避开‌上表中的所有端口尤其是 6665-6669、6000、10080 这些开发中容易误用的。
阅读完成 · 觉得有帮助?
咨询建站